Firefox 4 is a major version upgrade for the web browser, and consequently, add-ons, plug-ins or extensions which have not been updated to run properly on Firefox 4 will not be compatible with Firefox 4. Early adopters who have upgrade to Firefox 4 Beta 1, there are in fact a lot of incompatible extensions been detected, and automatically disabled by Firefox 4 Beta.

In fact, some plugins, addons or extensions may be able to continue to work properly in Firefox 4, despite been labeled as incompatible by the web browser. Hopefully, by default Firefox will not allowed any incompatible extension, addon or plugin to be installed or enabled.

Incompatitble Extensions in Firefox 4

Use the trick below to disable and turn off Firefox 4 extensions compatibility check so that incompatible extensions can be installed or enabled.

  1. In Firefox 4 Beta, type about:config into the address bar, and hit Enter or Go.
  2. Click on I’ll be careful, I promise! button at the warning prompt.
  3. Right click on the window, and select New -> Boolean.
  4. Enter extensions.checkCompatibility.4.0b as the preference name.

    extensions.checkCompatibility.4.0b

  5. Set its value to False.

    Disable Firefox 4 Beta Extensions Compatibility Check

  6. User can now install or re-enable incompatible extensions.

    Enable Incompatible Add-Ons in Firefox 4 Beta

    Note: It’s important to understand that not all extension will work perfectly in new version of Firefox, especially when it’s been tagged as incompatible.

Update: Disable Add-ons Compatibility Check in Firefox 4

Related Posts